| Package | Affected versions | Patched versions |
|---|---|---|
| glib | < 2.89.0 | 2.89.0 |
| cert-manager operator | = 1.17.0= 1.20.0≥ 1.18.0, < 1.18.2 | 1.18.2 |
| codeready linux builder | = 10.0= 8.0= 9.0 | |
| codeready linux builder eus | = 10.0= 9.6 | |
| discovery | = 2.0 | |
| insights-proxy | = 1.5.0 | |
| openshift ai | ≥ 3.0, < 3.0.3≥ 3.2, < 3.2.3≥ 3.4, < 3.4.3 | 3.0.33.2.33.4.3 |
| update infrastructure | ≥ 5.0, < 5.2 | 5.2 |
A flaw was found in GLib. A state confusion issue exists in g_dbus_node_info_new_for_xml() in the gio/gdbusintrospection.c file when processing malformed D-Bus introspection XML, specifically with a `node` element nested within other elements like `method`, `signal`, `property` or `arg`. This issue can cause an unsigned integer overflow and lead to an out-of-bounds read, resulting in a denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free