要点
- CVE-2026-94482 是影响 next 的高危 (CVSS 8.2)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.39%,高于 32.7% 的漏洞。
- 修复:升级到 15.5.28, 16.4.1 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| next npm | ≥ 13.0.0, < 15.5.28≥ 16.0.0, < 16.4.1
| 15.5.2816.4.1
|
Description
Impact
Crafted requests targeting Next.js applications using App Router with at least one Server Action can lead to excessive CPU usage blocking processing of further requests in the same process.
Workarounds
No workaround exists besides upgrading. Applications using Pages Router or not using Server Actions are not vulnerable.
NVD description
Next.js is a React framework for building full-stack web applications. From 13.0.0 until 15.5.28 and 16.4.1, crafted requests targeting App Router applications with at least one Server Action can cause excessive CPU consumption and block processing of further requests in the same process. Applications using the Pages Router and App Router applications without Server Actions are not affected. This issue is fixed in versions 15.5.28 and 16.4.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free