In short
- CVE-2009-5012 is a MEDIUM (CVSS 4.0) vulnerability affecting pyftpdlib, pyftpdlib (g.rodola).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 63.2% of all vulnerabilities.
- Fix: update to 0.5.2 or later.
| Package | Affected versions | Patched versions |
|---|
| pyftpdlib PyPI | < 0.5.2
| 0.5.2
|
| pyftpdlib | = 0.1= 0.1.1= 0.2.0= 0.3.0= 0.4.0= 0.5.0≤ 0.5.1
| No fix yet |
Description
ftpserver.py in pyftpdlib before 0.5.2 does not require the l permission for the MLST command, which allows remote authenticated users to bypass intended access restrictions and list the root directory via an FTP session.
NVD description
ftpserver.py in pyftpdlib before 0.5.2 does not require the l permission for the MLST command, which allows remote authenticated users to bypass intended access restrictions and list the root directory via an FTP session.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free