In short
- CVE-2009-5013 is a MEDIUM (CVSS 4.0) vulnerability affecting pyftpdlib, pyftpdlib (g.rodola).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.9% of all vulnerabilities.
- Fix: update to 0.5.2 or later.
| Package | Affected versions | Patched versions |
|---|
| pyftpdlib PyPI | < 0.5.2
| 0.5.2
|
| pyftpdlib | = 0.1= 0.1.1= 0.2.0= 0.3.0= 0.4.0= 0.5.0≤ 0.5.1
| No fix yet |
Description
Memory leak in the on_dtp_close function in ftpserver.py in pyftpdlib before 0.5.2 allows remote authenticated users to cause a denial of service (memory consumption) by sending a QUIT command during a data transfer.
NVD description
Memory leak in the on_dtp_close function in ftpserver.py in pyftpdlib before 0.5.2 allows remote authenticated users to cause a denial of service (memory consumption) by sending a QUIT command during a data transfer.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free