In short
- CVE-2011-1028 is a CRITICAL (CVSS 9.8) vulnerability affecting smarty/smarty, smarty (smarty).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 76.0% of all vulnerabilities.
- Fix: update to 3.0.7 or later.
| Package | Affected versions | Patched versions |
|---|
| smarty/smarty Packagist | < 3.0.7
| 3.0.7
|
| smarty | ≥ 3.0.0, < 3.0.7
| 3.0.7
|
Description
The $smarty.template variable in Smarty3 allows attackers to possibly execute arbitrary PHP code via the sysplugins/smarty_internal_compile_private_special_variable.php file.
NVD description
The $smarty.template variable in Smarty3 allows attackers to possibly execute arbitrary PHP code via the sysplugins/smarty_internal_compile_private_special_variable.php file.
More vulnerabilities in smarty/smarty
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free