In short
- CVE-2024-35226 is a HIGH (CVSS 7.3) vulnerability affecting smarty/smarty.
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 43.3% of all vulnerabilities.
- Fix: update to 4.5.3, 5.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| smarty/smarty Packagist | ≥ 3.0.0, < 4.5.3≥ 5.0.0, < 5.1.1
| 4.5.35.1.1
|
Description
Impact
Template authors could inject php code by choosing a malicous file name for an extends-tag. Users that cannot fully trust template authors should update asap.
Patches
Please upgrade to the most recent version of Smarty v4 or v5. There is no patch for v3.
NVD description
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. In affected versions template authors could inject php code by choosing a malicious file name for an extends-tag. Sites that cannot fully trust template authors should update asap. All users are advised to update. There is no patch for users on the v3 branch. There are no known workarounds for this vulnerability.
More vulnerabilities in smarty/smarty
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free