In short
- CVE-2018-25047 is a MEDIUM (CVSS 5.4) vulnerability affecting smarty/smarty, smarty (smarty).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 65.7% of all vulnerabilities.
- Fix: update to 4.2.1, 3.1.47 or later.
| Package | Affected versions | Patched versions |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.2.1< 3.1.47
| 4.2.13.1.47
|
| smarty | ≥ 4.0.0, < 4.2.1< 3.1.47
| 4.2.13.1.47
|
Description
In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows cross-site scripting. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.
NVD description
In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.
More vulnerabilities in smarty/smarty
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free