In short
- CVE-2011-1157 is a MEDIUM (CVSS 4.3) vulnerability affecting feedparser, feedparser (mark pilgrim).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.5% of all vulnerabilities.
- Fix: update to 5.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| feedparser PyPI | ≥ 5.0, < 5.0.1< 5.0.1
| 5.0.1
|
| feedparser | = 5.0
| No fix yet |
Description
Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) 5.x before 5.0.1 allows remote attackers to inject arbitrary web script or HTML via malformed XML comments.
NVD description
Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) 5.x before 5.0.1 allows remote attackers to inject arbitrary web script or HTML via malformed XML comments.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free