In short
- CVE-2013-2100 is a CRITICAL (CVSS 9.3) vulnerability affecting portage, portage (gentoo).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.4% of all vulnerabilities.
- Fix: update to 2.1.12.2 or later.
| Package | Affected versions | Patched versions |
|---|
| portage PyPI | < 2.1.12.2all versions
| 2.1.12.2
|
| portage | = 2.1.12
| No fix yet |
Description
The urlopen function in pym/portage/util/_urlopen.py in Gentoo Portage 2.1.12, when using HTTPS, does not verify X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers and modify binary package lists via a crafted certificate.
NVD description
The urlopen function in pym/portage/util/_urlopen.py in Gentoo Portage 2.1.12, when using HTTPS, does not verify X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers and modify binary package lists via a crafted certificate.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free