In short
- CVE-2016-20021 is a CRITICAL (CVSS 9.8) vulnerability affecting portage, portage (gentoo).
- Chance of exploitation in the next 30 days (EPSS): 0.47%, higher than 40.5% of all vulnerabilities.
- Fix: update to 3.0.47 or later.
| Package | Affected versions | Patched versions |
|---|
| portage PyPI | < 3.0.47
| 3.0.47
|
| portage | < 3.0.47
| 3.0.47
|
Description
In Gentoo Portage before 3.0.47, there is missing PGP validation of executed code: the standalone emerge-webrsync downloads a .gpgsig file but does not perform signature verification.
NVD description
In Gentoo Portage before 3.0.47, there is missing PGP validation of executed code: the standalone emerge-webrsync downloads a .gpgsig file but does not perform signature verification. Unless emerge-webrsync is used, Portage is not vulnerable.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free