In short
- CVE-2014-10077 is a HIGH (CVSS 7.5) vulnerability affecting i18n, i18n (i18n project).
- Chance of exploitation in the next 30 days (EPSS): 3.4%, higher than 88.9% of all vulnerabilities.
- Fix: update to 0.8.0 or later.
| Package | Affected versions | Patched versions |
|---|
| i18n RubyGems | < 0.8.0
| 0.8.0
|
| i18n | < 0.8.0
| 0.8.0
|
Description
Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.
NVD description
Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free