In short
- CVE-2014-7808 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.wicket:wicket-core, wicket (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 65.8% of all vulnerabilities.
- Fix: update to 6.19.0, 7.0.0-M5, 1.5.13 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.wicket:wicket-core Maven | ≥ 6.0.0-beta1, < 6.19.0≥ 7.0.0-M1, < 7.0.0-M5< 1.5.13
| 6.19.07.0.0-M51.5.13
|
| wicket | = 7.0.0≥ 1.5.0, < 1.5.13≥ 6.0.0, < 6.19.0
| 1.5.136.19.0
|
Description
Apache Wicket before 1.5.13, 6.x before 6.19.0, and 7.x before 7.0.0-M5 make it easier for attackers to defeat a cryptographic protection mechanism and predict encrypted URLs by leveraging use of CryptoMapper as the default encryption provider.
NVD description
Apache Wicket before 1.5.13, 6.x before 6.19.0, and 7.x before 7.0.0-M5 make it easier for attackers to defeat a cryptographic protection mechanism and predict encrypted URLs by leveraging use of CryptoMapper as the default encryption provider.
More vulnerabilities in org.apache.wicket:wicket-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free