In short
- CVE-2015-2963 is a MEDIUM (CVSS 4.3) vulnerability affecting paperclip, paperclip (thoughtbot).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.8% of all vulnerabilities.
- Fix: update to 4.2.2 or later.
| Package | Affected versions | Patched versions |
|---|
| paperclip RubyGems | < 4.2.2
| 4.2.2
|
| paperclip | ≤ 4.2.1
| No fix yet |
Description
The thoughtbot paperclip gem before 4.2.2 for Ruby does not consider the content-type value during media-type validation, which allows remote attackers to upload HTML documents and conduct cross-site scripting (XSS) attacks via a spoofed value, as demonstrated by image/jpeg.
NVD description
The thoughtbot paperclip gem before 4.2.2 for Ruby does not consider the content-type value during media-type validation, which allows remote attackers to upload HTML documents and conduct cross-site scripting (XSS) attacks via a spoofed value, as demonstrated by image/jpeg.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free