In short
- CVE-2017-0889 is a CRITICAL (CVSS 9.8) vulnerability affecting paperclip, paperclip (thoughtbot).
- Chance of exploitation in the next 30 days (EPSS): 3.1%, higher than 87.6% of all vulnerabilities.
- Fix: update to 5.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| paperclip RubyGems | ≥ 3.1.4, < 5.2.0
| 5.2.0
|
| paperclip | ≥ 3.1.4, < 5.2.0
| 5.2.0
|
Description
Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.
NVD description
Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free