| Package | Affected versions | Patched versions |
|---|---|---|
| rubygems-update | ≥ 2.0.0, < 2.0.16≥ 2.2.0, < 2.2.4≥ 2.4.0, < 2.4.7 | 2.0.162.2.42.4.7 |
| ruby | = 1.9= 1.9.1= 1.9.2= 1.9.3= 2.0.0= 2.1= 2.1.1= 2.1.2= 2.1.3= 2.1.4= 2.1.5= 2.2.0 | |
| rubygems | = 2.0.0= 2.0.1= 2.0.10= 2.0.11= 2.0.12= 2.0.13= 2.0.14= 2.0.15= 2.0.2= 2.0.3= 2.0.4= 2.0.5= 2.0.6= 2.0.7= 2.0.8= 2.0.9= 2.2.0= 2.2.1= 2.2.2= 2.2.3= 2.4.0= 2.4.1= 2.4.2= 2.4.3= 2.4.4= 2.4.5= 2.4.6 |
RubyGems 2.0.x before 2.0.16, 2.2.x before 2.2.4, and 2.4.x before 2.4.7 does not validate the hostname when fetching gems or making API requests, which allows remote attackers to redirect requests to arbitrary domains via a crafted DNS SRV record, aka a "DNS hijack attack."
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free