In short
- CVE-2015-4411 is a HIGH (CVSS 7.5) vulnerability affecting bson, bson (mongodb).
- Chance of exploitation in the next 30 days (EPSS): 6.4%, higher than 93.7% of all vulnerabilities.
- Fix: update to 3.0.4 or later.
| Package | Affected versions | Patched versions |
|---|
| bson RubyGems | < 3.0.4
| 3.0.4
|
| bson | < 3.0.4
| 3.0.4
|
Description
The Moped::BSON::ObjecId.legal? method in mongodb/bson-ruby before 3.0.4 as used in rubygem-moped allows remote attackers to cause a denial of service (worker resource consumption) via a crafted string. NOTE: This issue is due to an incomplete fix to CVE-2015-4410.
NVD description
The Moped::BSON::ObjecId.legal? method in mongodb/bson-ruby before 3.0.4 as used in rubygem-moped allows remote attackers to cause a denial of service (worker resource consumption) via a crafted string. NOTE: This issue is due to an incomplete fix to CVE-2015-4410.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free