In short
- CVE-2015-4412 is a CRITICAL (CVSS 9.8) vulnerability affecting bson, bson (bson project).
- Chance of exploitation in the next 30 days (EPSS): 4.7%, higher than 91.8% of all vulnerabilities.
- Fix: update to 3.0.4, 1.12.3 or later.
| Package | Affected versions | Patched versions |
|---|
| bson RubyGems | ≥ 2.0, < 3.0.4< 1.12.3
| 3.0.41.12.3
|
| bson | = 3.0.3
| No fix yet |
Description
BSON injection vulnerability in the legal function in BSON (bson-ruby) gem before 3.0.4 for Ruby allows remote attackers to cause a denial of service (resource consumption) or inject arbitrary data via a crafted string.
NVD description
BSON injection vulnerability in the legal? function in BSON (bson-ruby) gem before 3.0.4 for Ruby allows remote attackers to cause a denial of service (resource consumption) or inject arbitrary data via a crafted string.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free