In short
- CVE-2015-8557 is a CRITICAL (CVSS 9.0) vulnerability affecting pygments, pygments (pygments).
- Chance of exploitation in the next 30 days (EPSS): 6.7%, higher than 93.9% of all vulnerabilities.
- Fix: update to 2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pygments PyPI | ≥ 1.2.2, < 2.1
| 2.1
|
| pygments | = 1.2.2= 1.3= 1.3.1= 1.4= 1.5= 1.6= 2.0= 2.0.1
| No fix yet |
Description
The FontManager._get_nix_font_path function in formatters/img.py in Pygments 1.2.2 through 2.0.2 allows remote attackers to execute arbitrary commands via shell metacharacters in a font name.
NVD description
The FontManager._get_nix_font_path function in formatters/img.py in Pygments 1.2.2 through 2.0.2 allows remote attackers to execute arbitrary commands via shell metacharacters in a font name.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free