In short
- CVE-2022-40896 is a MEDIUM (CVSS 5.5) vulnerability affecting pygments, pygments (pygments).
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 44.1% of all vulnerabilities.
- Fix: update to 2.15.0, 2.15.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pygments PyPI | < 2.15.0< 2.15.1
| 2.15.02.15.1
|
| pygments | ≤ 2.15.0
| No fix yet |
Description
A ReDoS issue was discovered in pygments/lexers/smithy.py in Pygments until 2.15.0 via SmithyLexer.
NVD description
A ReDoS issue was discovered in pygments/lexers/smithy.py in pygments through 2.15.0 via SmithyLexer.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free