In short
- CVE-2016-20018 is a HIGH (CVSS 7.5) vulnerability affecting knex (knexjs), knex.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.2% of all vulnerabilities.
- Fix: update to 2.4.0 or later.
| Package | Affected versions | Patched versions |
|---|
| knex | ≤ 2.3.0
| No fix yet |
| knex npm | < 2.4.0
| 2.4.0
|
Description
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. This vulnerability has been fixed in version 2.4.0.
NVD description
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free