In short
- CVE-2019-10757 is a CRITICAL (CVSS 9.8) vulnerability affecting knex (knexjs), knex.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.3% of all vulnerabilities.
- Fix: update to 0.19.5 or later.
| Package | Affected versions | Patched versions |
|---|
| knex | < 0.19.5
| 0.19.5
|
| knex npm | < 0.19.5
| 0.19.5
|
Description
knex.js versions before 0.19.5 are vulnerable to SQL Injection attack. Identifiers are escaped incorrectly as part of the MSSQL dialect, allowing attackers to craft a malicious query to the host DB.
NVD description
knex.js versions before 0.19.5 are vulnerable to SQL Injection attack. Identifiers are escaped incorrectly as part of the MSSQL dialect, allowing attackers to craft a malicious query to the host DB.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free