In short
- CVE-2016-3693 is a HIGH (CVSS 8.1) vulnerability affecting safemode, safemode (safemode project).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 82.0% of all vulnerabilities.
- Fix: update to 1.2.4 or later.
| Package | Affected versions | Patched versions |
|---|
| safemode RubyGems | < 1.2.4
| 1.2.4
|
| safemode | ≤ 1.2.3
| No fix yet |
Description
The Safemode gem before 1.2.4 for Ruby, when initialized with a delegate object that is a Rails controller, allows context-dependent attackers to obtain sensitive information via the inspect method.
NVD description
The Safemode gem before 1.2.4 for Ruby, when initialized with a delegate object that is a Rails controller, allows context-dependent attackers to obtain sensitive information via the inspect method.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free