In short
- CVE-2017-7540 is a CRITICAL (CVSS 9.8) vulnerability affecting safemode, safemode (safemode project).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 76.3% of all vulnerabilities.
- Fix: update to 1.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| safemode RubyGems | < 1.3.2
| 1.3.2
|
| safemode | ≤ 1.3.2
| No fix yet |
Description
rubygem-safemode, as used in Foreman, versions 1.3.1 and earlier are vulnerable to bypassing safe mode limitations via special Ruby syntax. This can lead to deletion of objects for which the user does not have delete permissions or possibly to privilege escalation.
NVD description
rubygem-safemode, as used in Foreman, versions 1.3.2 and earlier are vulnerable to bypassing safe mode limitations via special Ruby syntax. This can lead to deletion of objects for which the user does not have delete permissions or possibly to privilege escalation.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free