In short
- CVE-2017-0902 is a HIGH (CVSS 8.1) vulnerability affecting rubygems-update, rubygems (rubygems).
- Chance of exploitation in the next 30 days (EPSS): 4.8%, higher than 91.9% of all vulnerabilities.
- Fix: update to 2.6.13 or later.
Description
RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.
NVD description
RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.
More vulnerabilities in rubygems-update
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free