In short
- CVE-2017-1000070 is a MEDIUM (CVSS 6.1) vulnerability affecting github.com/bitly/oauth2_proxy, oauth2 proxy (oauth2 proxy project).
- Chance of exploitation in the next 30 days (EPSS): 1.00%, higher than 62.7% of all vulnerabilities.
- Fix: update to 2.2.0 or later.
Description
The Bitly oauth2_proxy in version 2.1 and earlier was affected by an open redirect vulnerability during the start and termination of the 2-legged OAuth flow. This issue was caused by improper input validation and a violation of RFC-6819
NVD description
The Bitly oauth2_proxy in version 2.1 and earlier was affected by an open redirect vulnerability during the start and termination of the 2-legged OAuth flow. This issue was caused by improper input validation and a violation of RFC-6819
More vulnerabilities in github.com/bitly/oauth2_proxy
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free