In short
- CVE-2017-1000089 is a MEDIUM (CVSS 5.3) vulnerability affecting org.jenkins-ci.plugins:pipeline-build-step, pipeline (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.96%, higher than 61.5% of all vulnerabilities.
- Fix: update to 2.5.1 or later.
Description
Builds in Jenkins are associated with an authentication that controls the permissions that the build has to interact with other elements in Jenkins. The Pipeline: Build Step Plugin did not check the build authentication it was running as and allowed triggering any other project in Jenkins.
NVD description
Builds in Jenkins are associated with an authentication that controls the permissions that the build has to interact with other elements in Jenkins. The Pipeline: Build Step Plugin did not check the build authentication it was running as and allowed triggering any other project in Jenkins.
More vulnerabilities in org.jenkins-ci.plugins:pipeline-build-step
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free