In short
- CVE-2022-25184 is a MEDIUM (CVSS 6.5) vulnerability affecting org.jenkins-ci.plugins:pipeline-build-step, pipeline (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.88%, higher than 59.0% of all vulnerabilities.
- Fix: update to 2.15.1 or later.
Description
Jenkins Pipeline: Build Step Plugin 2.15 and earlier reveals password parameter default values when generating a pipeline script using the Pipeline Snippet Generator, allowing attackers with Item/Read permission to retrieve the default password parameter value from jobs.
NVD description
Jenkins Pipeline: Build Step Plugin 2.15 and earlier reveals password parameter default values when generating a pipeline script using the Pipeline Snippet Generator, allowing attackers with Item/Read permission to retrieve the default password parameter value from jobs.
More vulnerabilities in org.jenkins-ci.plugins:pipeline-build-step
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free