In short
- CVE-2017-1000480 is a CRITICAL (CVSS 9.8) vulnerability affecting smarty/smarty, smarty (smarty).
- Chance of exploitation in the next 30 days (EPSS): 3.1%, higher than 87.9% of all vulnerabilities.
- Fix: update to 3.1.32 or later.
| Package | Affected versions | Patched versions |
|---|
| smarty/smarty Packagist | ≥ 3, < 3.1.32
| 3.1.32
|
| smarty | ≥ 3.0.0, < 3.1.32
| 3.1.32
|
Description
Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.
NVD description
Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.
More vulnerabilities in smarty/smarty
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free