In short
- CVE-2017-11516 is a MEDIUM (CVSS 6.1) vulnerability affecting yiisoft/yii2, yiisoft/yii2-dev, yii (yiiframework).
- Chance of exploitation in the next 30 days (EPSS): 0.83%, higher than 57.6% of all vulnerabilities.
- Fix: update to 2.0.13 or later.
| Package | Affected versions | Patched versions |
|---|
| yiisoft/yii2 Packagist | ≥ 2.0.12, < 2.0.13
| 2.0.13
|
| yiisoft/yii2-dev Packagist | ≥ 2.0.12, < 2.0.13
| 2.0.13
|
| yii | = 2.0.12
| No fix yet |
Description
An XSS vulnerability exists in framework/views/errorHandler/exception.php in Yii Framework 2.0.12 affecting the exception screen when debug mode is enabled, because $exception->errorInfo is mishandled.
NVD description
An XSS vulnerability exists in framework/views/errorHandler/exception.php in Yii Framework 2.0.12 affecting the exception screen when debug mode is enabled, because $exception->errorInfo is mishandled.
More vulnerabilities in yiisoft/yii2
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free