In short
- CVE-2017-15284 is a MEDIUM (CVSS 5.4) vulnerability affecting october/rain, october (octobercms).
- Chance of exploitation in the next 30 days (EPSS): 4.0%, higher than 90.6% of all vulnerabilities.
- Fix: update to 1.0.426 or later.
| Package | Affected versions | Patched versions |
|---|
| october/rain Packagist | < 1.0.426
| 1.0.426
|
| october | = 1.0.425
| No fix yet |
Description
Cross-Site Scripting exists in OctoberCMS 1.0.425 (aka Build 425), allowing a least privileged user to upload an SVG file containing malicious code as the Avatar for the profile. When this is opened by the Admin, it causes JavaScript execution in the context of the Admin account.
NVD description
Cross-Site Scripting exists in OctoberCMS 1.0.425 (aka Build 425), allowing a least privileged user to upload an SVG file containing malicious code as the Avatar for the profile. When this is opened by the Admin, it causes JavaScript execution in the context of the Admin account.
More vulnerabilities in october/rain
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free