In short
- CVE-2026-25133 is a MEDIUM (CVSS 4.8) vulnerability affecting october/rain, october (octobercms).
- Chance of exploitation in the next 30 days (EPSS): 0.22%, higher than 12.2% of all vulnerabilities.
- Fix: update to 4.1.10, 3.7.14 or later.
| Package | Affected versions | Patched versions |
|---|
| october/rain Packagist | ≥ 4.0.0, < 4.1.10< 3.7.14
| 4.1.103.7.14
|
| october | ≥ 4.0.0, ≤ 4.1.9≤ 3.7.13
| No fix yet |
Description
A stored cross-site scripting (XSS) vulnerability was identified in the SVG sanitization logic. The regex pattern used to strip on* event handler attributes could be bypassed using a crafted payload that exploits how the pattern matches attribute boundaries.
Impact
- Stored XSS via malicious SVG files uploaded through the Media Manager
- Could allow privilege escalation if a superuser views or embeds the malicious SVG
- Requires authenticated backend access with media upload permissions (
media.library.create)
- SVG must be viewed or embedded in a page to trigger
Patches
The vulnerability has been patched in v3.7.14 and v4.1.10. All users are encouraged to upgrade to the latest patched version.
Workarounds
If upgrading immediately is not possible:
- Disable SVG uploads by adding
svg to the blocked extensions in media configuration
- Set
media.clean_vectors to true in configuration (enabled by default)
References
- Reported by Pentest-Tools.com
NVD description
October is a Content Management System (CMS) and web platform. Versions prior to 3.7.14 and 4.1.10 contain a stored cross-site scripting (XSS) vulnerability in the SVG sanitization logic. The regex pattern used to strip event handler attributes (such as onclick or onload) could be bypassed using a crafted payload that exploits how the pattern matches attribute boundaries, allowing malicious SVG files to be uploaded through the Media Manager with embedded JavaScript. Exploitation could lead to privilege escalation if a superuser views or embeds the malicious SVG, and requires authenticated backend access with media upload permissions. The SVG must be viewed or embedded in a page for the payload to trigger. This issue has been fixed in versions 3.7.14 and 4.1.10.
More vulnerabilities in october/rain
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free