In short
- CVE-2017-15928 is a HIGH (CVSS 7.5) vulnerability affecting ox, ox (ox project).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.5% of all vulnerabilities.
- Fix: update to 2.8.1 or later.
| Package | Affected versions | Patched versions |
|---|
| ox RubyGems | < 2.8.1
| 2.8.1
|
| ox | = 2.8.0
| No fix yet |
Description
In the Ox gem 2.8.0 for Ruby, the process crashes with a segmentation fault when a crafted input is supplied to parse_obj. NOTE: the vendor has stated "Ox should handle the error more gracefully" but has not confirmed a security implication.
NVD description
In the Ox gem 2.8.0 for Ruby, the process crashes with a segmentation fault when a crafted input is supplied to parse_obj. NOTE: the vendor has stated "Ox should handle the error more gracefully" but has not confirmed a security implication.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free