In short
- CVE-2017-16229 is a MEDIUM (CVSS 5.5) vulnerability affecting ox, ox (ox project).
- Chance of exploitation in the next 30 days (EPSS): 0.97%, higher than 61.8% of all vulnerabilities.
- Fix: update to 2.8.2 or later.
| Package | Affected versions | Patched versions |
|---|
| ox RubyGems | < 2.8.2
| 2.8.2
|
| ox | = 2.8.1
| No fix yet |
Description
In the Ox gem 2.8.1 for Ruby, the process crashes with a stack-based buffer over-read in the read_from_str function in sax_buf.c when a crafted input is supplied to sax_parse.
NVD description
In the Ox gem 2.8.1 for Ruby, the process crashes with a stack-based buffer over-read in the read_from_str function in sax_buf.c when a crafted input is supplied to sax_parse.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free