In short
- CVE-2017-16015 is a MEDIUM (CVSS 6.1) vulnerability affecting forms (forms project), forms.
- Chance of exploitation in the next 30 days (EPSS): 0.83%, higher than 57.9% of all vulnerabilities.
- Fix: update to 1.3.0 or later.
| Package | Affected versions | Patched versions |
|---|
| forms | < 1.3.0
| 1.3.0
|
| forms npm | < 1.3.0
| 1.3.0
|
Description
Affected versions of forms do not properly escape HTML in generated forms, which may result in cross-site scripting.
Recommendation
Update to version 1.3.0 or later.
NVD description
Forms is a library for easily creating HTML forms. Versions before 1.3.0 did not have proper html escaping. This means that if the application did not sanitize html on behalf of forms, use of forms may be vulnerable to cross site scripting
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free