In short
- CVE-2021-23388 is a MEDIUM (CVSS 5.3) vulnerability affecting forms (forms project), forms.
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 76.6% of all vulnerabilities.
- Fix: update to 1.3.2, 1.2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| forms | ≥ 1.3.0, < 1.3.2< 1.2.1
| 1.3.21.2.1
|
| forms npm | < 1.3.2
| 1.3.2
|
Description
The package forms before 1.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via email validation.
NVD description
The package forms before 1.2.1, from 1.3.0 and before 1.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via email validation.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free