In short
- CVE-2017-2651 is a LOW (CVSS 3.7) vulnerability affecting org.jenkins-ci.plugins:mailer, mailer (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 76.0% of all vulnerabilities.
- Fix: update to 1.20 or later.
Description
jenkins-mailer-plugin before version 1.20 is vulnerable to an information disclosure while using the feature to send emails to a dynamically created list of users based on the changelogs. This could in some cases result in emails being sent to people who have no user account in Jenkins, and in rare cases even people who were not involved in whatever project was being built, due to some mapping based on the local-part of email addresses.
NVD description
jenkins-mailer-plugin before version 1.20 is vulnerable to an information disclosure while using the feature to send emails to a dynamically created list of users based on the changelogs. This could in some cases result in emails being sent to people who have no user account in Jenkins, and in rare cases even people who were not involved in whatever project was being built, due to some mapping based on the local-part of email addresses.
More vulnerabilities in org.jenkins-ci.plugins:mailer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free