In short
- CVE-2017-5946 is a CRITICAL (CVSS 9.8) vulnerability affecting rubyzip, rubyzip (rubyzip project).
- Chance of exploitation in the next 30 days (EPSS): 3.4%, higher than 89.0% of all vulnerabilities.
- Fix: update to 1.2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| rubyzip RubyGems | < 1.2.1
| 1.2.1
|
| rubyzip | < 1.2.1
| 1.2.1
|
Description
The Zip::File component in the rubyzip gem before 1.2.1 for Ruby has a directory traversal vulnerability. If a site allows uploading of .zip files, an attacker can upload a malicious file that uses ../ pathname substrings to write arbitrary files to the filesystem.
NVD description
The Zip::File component in the rubyzip gem before 1.2.1 for Ruby has a directory traversal vulnerability. If a site allows uploading of .zip files, an attacker can upload a malicious file that uses "../" pathname substrings to write arbitrary files to the filesystem.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free