In short
- CVE-2026-85396 is a HIGH (CVSS 7.5) vulnerability affecting rubyzip.
- Chance of exploitation in the next 30 days (EPSS): 0.56%, higher than 46.9% of all vulnerabilities.
- Fix: update to 3.4.0 or later.
| Package | Affected versions | Patched versions |
|---|
| rubyzip RubyGems | < 3.4.0
| 3.4.0
|
Description
rubyzip versions before 3.4.0 contain a path traversal vulnerability in Zip::Entry#extract that fails to properly validate extraction paths using prefix comparison without trailing separators. Attackers can craft archive entries with names like ../upload_backup/owned.sh to write files outside the intended extraction directory into sibling paths sharing the destination prefix.
NVD description
rubyzip versions before 3.4.0 contain a path traversal vulnerability in Zip::Entry#extract that fails to properly validate extraction paths using prefix comparison without trailing separators. Attackers can craft archive entries with names like ../upload_backup/owned.sh to write files outside the intended extraction directory into sibling paths sharing the destination prefix.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free