In short
- CVE-2017-9790 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.mesos:mesos, mesos (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 84.3% of all vulnerabilities.
- Fix: update to 1.2.2, 1.3.1, 1.1.3 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.mesos:mesos Maven | ≥ 1.2.0, < 1.2.2≥ 1.3.0, < 1.3.1< 1.1.3
| 1.2.21.3.11.1.3
|
| mesos | = 1.2.0= 1.2.1= 1.3.0= 1.3.1= 1.4.0-dev≤ 1.1.2
| No fix yet |
Description
When handling a libprocess message wrapped in an HTTP request, libprocess in Apache Mesos before 1.1.3, 1.2.x before 1.2.2, 1.3.x before 1.3.1, and 1.4.0-dev crashes if the request path is empty, because the parser assumes the request path always starts with '/'. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
NVD description
When handling a libprocess message wrapped in an HTTP request, libprocess in Apache Mesos before 1.1.3, 1.2.x before 1.2.2, 1.3.x before 1.3.1, and 1.4.0-dev crashes if the request path is empty, because the parser assumes the request path always starts with '/'. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
More vulnerabilities in org.apache.mesos:mesos
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free