In short
- CVE-2018-1330 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.mesos:mesos, mesos (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.7%, higher than 89.9% of all vulnerabilities.
- Fix: update to 1.6.0, 1.4.2, 1.5.1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.mesos:mesos Maven | ≥ 1.4.0, < 1.6.0
| 1.6.0
|
| mesos | = 1.4.0= 1.6.0≥ 1.4.0, < 1.4.2≥ 1.5.0, < 1.5.1
| 1.4.21.5.1
|
Description
When parsing a malformed JSON payload, libprocess in Apache Mesos versions 1.4.0 to 1.5.0 might crash due to an uncaught exception. Parsing chunked HTTP requests with trailers can lead to a libprocess crash too because of the mistakenly planted assertion. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
NVD description
When parsing a malformed JSON payload, libprocess in Apache Mesos versions 1.4.0 to 1.5.0 might crash due to an uncaught exception. Parsing chunked HTTP requests with trailers can lead to a libprocess crash too because of the mistakenly planted assertion. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
More vulnerabilities in org.apache.mesos:mesos
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free