In short
- CVE-2017-9799 is a HIGH (CVSS 8.8) vulnerability affecting org.apache.storm:storm-core, storm (apache).
- Chance of exploitation in the next 30 days (EPSS): 4.9%, higher than 92.1% of all vulnerabilities.
- Fix: update to 1.0.4, 1.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.storm:storm-core Maven | ≥ 1.0.0, < 1.0.4≥ 1.1.0, < 1.1.1
| 1.0.41.1.1
|
| storm | = 1.0= 1.0.1= 1.0.2= 1.0.3= 1.1
| No fix yet |
Description
It was found that under some situations and configurations of Apache Storm 1.x before 1.0.4 and 1.1.x before 1.1.1, it is theoretically possible for the owner of a topology to trick the supervisor to launch a worker as a different, non-root, user. In the worst case this could lead to secure credentials of the other user being compromised.
NVD description
It was found that under some situations and configurations of Apache Storm 1.x before 1.0.4 and 1.1.x before 1.1.1, it is theoretically possible for the owner of a topology to trick the supervisor to launch a worker as a different, non-root, user. In the worst case this could lead to secure credentials of the other user being compromised.
More vulnerabilities in org.apache.storm:storm-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free