In short
- CVE-2018-8008 is a MEDIUM (CVSS 5.5) vulnerability affecting org.apache.storm:storm-core, storm (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.9% of all vulnerabilities.
- Fix: update to 1.1.3, 1.2.2, 1.0.7 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.storm:storm-core Maven | ≥ 1.1.0, < 1.1.3≥ 1.2.0, < 1.2.2< 1.0.7
| 1.1.31.2.21.0.7
|
| storm | ≤ 1.0.6≤ 1.1.2≤ 1.2.1
| No fix yet |
Description
Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose an arbitrary file write vulnerability, that can be achieved using a specially crafted zip archive (affects other archives as well, bzip2, tar, xz, war, cpio, 7z), that holds path traversal filenames. So when the filename gets concatenated to the target extraction directory, the final path ends up outside of the target folder.
NVD description
Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose an arbitrary file write vulnerability, that can be achieved using a specially crafted zip archive (affects other archives as well, bzip2, tar, xz, war, cpio, 7z), that holds path traversal filenames. So when the filename gets concatenated to the target extraction directory, the final path ends up outside of the target folder.
More vulnerabilities in org.apache.storm:storm-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free