In short
- CVE-2018-1000012 is a HIGH (CVSS 8.8) vulnerability affecting org.jvnet.hudson.plugins:warnings, warnings (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.95%, higher than 61.2% of all vulnerabilities.
- Fix: update to 4.65 or later.
Description
Jenkins Warnings Plugin 4.64 and earlier processes XML external entities in files it parses as part of the build process, allowing attackers with user permissions in Jenkins to extract secrets from the Jenkins master, perform server-side request forgery, or denial-of-service attacks.
NVD description
Jenkins Warnings Plugin 4.64 and earlier processes XML external entities in files it parses as part of the build process, allowing attackers with user permissions in Jenkins to extract secrets from the Jenkins master, perform server-side request forgery, or denial-of-service attacks.
More vulnerabilities in org.jvnet.hudson.plugins:warnings
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free