In short
- CVE-2018-1000056 is a HIGH (CVSS 8.3) vulnerability affecting org.jenkins-ci.plugins:junit, junit (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 65.0% of all vulnerabilities.
- Fix: update to 1.24 or later.
Description
Jenkins JUnit Plugin 1.23 and earlier processes XML external entities in files it parses as part of the build process, allowing attackers with user permissions in Jenkins to extract secrets from the Jenkins master, perform server-side request forgery, or denial-of-service attacks.
NVD description
Jenkins JUnit Plugin 1.23 and earlier processes XML external entities in files it parses as part of the build process, allowing attackers with user permissions in Jenkins to extract secrets from the Jenkins master, perform server-side request forgery, or denial-of-service attacks.
More vulnerabilities in org.jenkins-ci.plugins:junit
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free