In short
- CVE-2018-1000421 is a MEDIUM (CVSS 6.5) vulnerability affecting org.jenkins-ci.plugins:mesos, mesos (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 70.3% of all vulnerabilities.
- Fix: update to 0.18 or later.
Description
An improper authorization vulnerability exists in Jenkins Mesos Plugin 0.17.1 and earlier in MesosCloud.java that allows attackers with Overall/Read access to initiate a test connection to an attacker-specified Mesos server with attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
NVD description
An improper authorization vulnerability exists in Jenkins Mesos Plugin 0.17.1 and earlier in MesosCloud.java that allows attackers with Overall/Read access to initiate a test connection to an attacker-specified Mesos server with attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
More vulnerabilities in org.jenkins-ci.plugins:mesos
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free