In short
- CVE-2018-1257 is a MEDIUM (CVSS 6.5) vulnerability affecting org.springframework:spring-core, agile product lifecycle management (oracle), application testing suite (oracle).
- Chance of exploitation in the next 30 days (EPSS): 3.0%, higher than 87.4% of all vulnerabilities.
- Fix: update to 5.0.6, 4.3.17, 7.0.0.1, 8.3 or later.
Description
Spring Framework, versions 5.0.x prior to 5.0.6, versions 4.3.x prior to 4.3.17, and older unsupported versions allows applications to expose STOMP over WebSocket endpoints with a simple, in-memory STOMP broker through the spring-messaging module. A malicious user (or attacker) can craft a message to the broker that can lead to a regular expression, denial of service attack.
NVD description
Spring Framework, versions 5.0.x prior to 5.0.6, versions 4.3.x prior to 4.3.17, and older unsupported versions allows applications to expose STOMP over WebSocket endpoints with a simple, in-memory STOMP broker through the spring-messaging module. A malicious user (or attacker) can craft a message to the broker that can lead to a regular expression, denial of service attack.
More vulnerabilities in org.springframework:spring-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free