In short
- CVE-2018-13982 is a HIGH (CVSS 7.5) vulnerability affecting smarty/smarty, smarty (smarty).
- Chance of exploitation in the next 30 days (EPSS): 3.5%, higher than 89.0% of all vulnerabilities.
- Fix: update to 3.1.33 or later.
| Package | Affected versions | Patched versions |
|---|
| smarty/smarty Packagist | < 3.1.33
| 3.1.33
|
| smarty | < 3.1.33
| 3.1.33
|
Description
Smarty_Security::isTrustedResourceDir() in Smarty before 3.1.33 is prone to a path traversal vulnerability due to insufficient template code sanitization. This allows attackers controlling the executed template code to bypass the trusted directory security restriction and read arbitrary files.
NVD description
Smarty_Security::isTrustedResourceDir() in Smarty before 3.1.33 is prone to a path traversal vulnerability due to insufficient template code sanitization. This allows attackers controlling the executed template code to bypass the trusted directory security restriction and read arbitrary files.
More vulnerabilities in smarty/smarty
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free