In short
- CVE-2018-18628 is a CRITICAL (CVSS 9.8) vulnerability affecting ro.pippo:pippo-core, pippo (pippo).
- Chance of exploitation in the next 30 days (EPSS): 5.5%, higher than 92.8% of all vulnerabilities.
- Fix: update to 1.12.0 or later.
Description
An issue was discovered in Pippo 1.11.0. The function SerializationSessionDataTranscoder.decode() calls ObjectInputStream.readObject() to deserialize a SessionData object without checking the object types. An attacker can create a malicious object, base64 encode it, and place it in the PIPPO_SESSION field of a cookie. Sending this cookie may lead to remote code execution.
NVD description
An issue was discovered in Pippo 1.11.0. The function SerializationSessionDataTranscoder.decode() calls ObjectInputStream.readObject() to deserialize a SessionData object without checking the object types. An attacker can create a malicious object, base64 encode it, and place it in the PIPPO_SESSION field of a cookie. Sending this cookie may lead to remote code execution.
More vulnerabilities in ro.pippo:pippo-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free