In short
- CVE-2018-20745 is a MEDIUM (CVSS 5.9) vulnerability affecting yiisoft/yii2, yii (yiiframework).
- Chance of exploitation in the next 30 days (EPSS): 0.54%, higher than 45.7% of all vulnerabilities.
- Fix: update to 2.0.16 or later.
| Package | Affected versions | Patched versions |
|---|
| yiisoft/yii2 Packagist | < 2.0.16
| 2.0.16
|
| yii | ≥ 2.0, ≤ 2.0.15.1
| No fix yet |
Description
Yii 2.x through 2.0.15.1 actively converts a wildcard CORS policy into reflecting an arbitrary Origin header value, which is incompatible with the CORS security design, and could lead to CORS misconfiguration security problems.
NVD description
Yii 2.x through 2.0.15.1 actively converts a wildcard CORS policy into reflecting an arbitrary Origin header value, which is incompatible with the CORS security design, and could lead to CORS misconfiguration security problems.
More vulnerabilities in yiisoft/yii2
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free