In short
- CVE-2018-7269 is a CRITICAL (CVSS 9.8) vulnerability affecting yiisoft/yii2-dev, yii (yiiframework).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.6% of all vulnerabilities.
- Fix: update to 2.0.13.2, 2.0.15, 2.0.12.1 or later.
| Package | Affected versions | Patched versions |
|---|
| yiisoft/yii2-dev Packagist | ≥ 2.0.13, < 2.0.13.2≥ 2.0.14, < 2.0.15< 2.0.12.1
| 2.0.13.22.0.152.0.12.1
|
| yii | ≥ 2.0.0, < 2.0.15
| 2.0.15
|
Description
The findByCondition function in framework/db/ActiveRecord.php in Yii 2.x before 2.0.15 allows remote attackers to conduct SQL injection attacks via a findOne() or findAll() call, unless a developer recognizes an undocumented need to sanitize array input.
NVD description
The findByCondition function in framework/db/ActiveRecord.php in Yii 2.x before 2.0.15 allows remote attackers to conduct SQL injection attacks via a findOne() or findAll() call, unless a developer recognizes an undocumented need to sanitize array input.
More vulnerabilities in yiisoft/yii2-dev
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free